Invalid parameter (PicShow)

Please post bug reports, feature requests, or any question regarding the DELPHI AREA products here.

Invalid parameter (PicShow)

Postby eballinas » September 17th, 2003, 8:14 pm

Exception...
Date : 09/17/2003 15:12:11
Address: 400B779B
Module : vcl60.bpl
Type : EOutOfResources
Message: El parámetro no es correcto. .

help me please
Delphi 6
Windows Xp
Picshow 3.06
eballinas
Active Member
Active Member
 
Posts: 9
Joined: September 17th, 2003, 8:11 pm
Location: México

copy

Postby eballinas » September 17th, 2003, 8:18 pm

By the way, I found the problem is when picshow is trying to copy the image.
I am using JPEG.
I tried BMP and I got the same error.
Please help me, because I had to delete the component from the project and I think the efects are beautiful
eballinas
Active Member
Active Member
 
Posts: 9
Joined: September 17th, 2003, 8:11 pm
Location: México

Postby Kambiz » September 17th, 2003, 8:56 pm

How big is your image's dimension? Could you please post a sample image here?
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm

Sample Image

Postby eballinas » September 18th, 2003, 12:42 am

I send a sample
eballinas
Active Member
Active Member
 
Posts: 9
Joined: September 17th, 2003, 8:11 pm
Location: México

Postby Johnny_Bit » September 18th, 2003, 2:47 pm

1. Image is too big (in dimensions and also in bytes)
2. Wv Tuxia? some commercial?
Johnny_Bit
VIP Member
VIP Member
 
Posts: 455
Joined: June 15th, 2003, 9:56 am

too big

Postby eballinas » September 18th, 2003, 3:20 pm

what is too big.
what is too small.
What is the accepted dimensions (does anybody know)?
eballinas
Active Member
Active Member
 
Posts: 9
Joined: September 17th, 2003, 8:11 pm
Location: México

Postby Kambiz » September 18th, 2003, 6:44 pm

Yes, the image is too big. With such a size of image even if PicShow doesn't raise an exception, the transition is too slow.

I suggest to do not use images bigger than about 640x480, or scale them to a smaller dimension before using in PicShow.
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm

Postby eballinas » September 19th, 2003, 7:12 pm

Could you be more especific.
I have resized my jpeg to 442X200.
I have the same error.
Help me.
eballinas
Active Member
Active Member
 
Posts: 9
Joined: September 17th, 2003, 8:11 pm
Location: México

Postby Kambiz » September 19th, 2003, 8:11 pm

Actually I didn't encounter to any problem in using PicShow with your images, even the big one.

Are you sure the problem is not because of some other part of your code?
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm

Postby eballinas » September 19th, 2003, 9:37 pm

If I delete your component, I do not have a problem
eballinas
Active Member
Active Member
 
Posts: 9
Joined: September 17th, 2003, 8:11 pm
Location: México

Postby eballinas » September 19th, 2003, 9:39 pm

when I change to a 70X180 pixeles, there was not a problem
eballinas
Active Member
Active Member
 
Posts: 9
Joined: September 17th, 2003, 8:11 pm
Location: México


Return to DELPHI AREA Products

Who is online

Users browsing this forum: No registered users and 1 guest