TLiveAudioRecorder Crash

Please post bug reports, feature requests, or any question regarding the DELPHI AREA products here.

TLiveAudioRecorder Crash

Postby xertia » August 17th, 2005, 2:40 am

**EDIT** I'VE FIXED THIS ISSUE NOW, THANKS.

Hello. Firstly, great set of components, excellent work.

Now to my problem. I am using TLiveAudioRecorder to capture sound from the system, then process this with lame_enc.dll and send the resulting mp3 data to a shoutcast server. This all works fine except when I try to deactivate the TLiveAudioRecorder component. When I set Active to False, the program crashes with an invalid pointer operation in the function ReallocateBuffer() in WaveIn.pas. I am making sure I set FreeIt to True in the OnData event, maybe pWaveHeader becomes a dangling pointer upon setting TLiveAudioRecorder.Active to False, so ReallocateBuffer thinks it isn't nil? I don't know. I make sure to use WaitForStop after deactivating also. I'm using 2 buffers, with varying BufferLength's depending on the bitrate & samplerate I need to work with. Async set to false, still crashes if set to true.

I am running Delphi 7.0 with Wave Audio Package v1.602 in Windows XP SP2.

Any ideas?

Thanks.
Attachments
crash1.gif
crash1.gif (12.86 KiB) Viewed 894 times
Last edited by xertia on August 18th, 2005, 2:11 am, edited 1 time in total.
xertia
Member
Member
 
Posts: 2
Joined: August 17th, 2005, 2:17 am

Fixed it

Postby xertia » August 18th, 2005, 2:09 am

Okay I fixed the issue. Wasn't allocating/unallocating my buffers with lame properly. All good now. :)
xertia
Member
Member
 
Posts: 2
Joined: August 17th, 2005, 2:17 am


Return to DELPHI AREA Products

Who is online

Users browsing this forum: No registered users and 2 guests