TPrintPreview visualization problems

Please post bug reports, feature requests, or any question regarding the DELPHI AREA products here.

TPrintPreview visualization problems

Postby flydragon » April 8th, 2005, 10:15 am

Hello!

I loaded into TPrintPreview a very big file rtf
(more than 1000 pages)...

and when I PaintRichText, the result is a rtf code instead a correct document.

Something like:
"{\rtf1\ansi\ansicpg1252\uc1\de..."

At first time I thought that the PlainText property of RichEdit was true, but it was false!

Probably the file is corrupt (I thought), but the file is correct, because if I save it to file from RichEdit and open with WordPad, the document is perfect.

I don't have more ideas...

Did someone ever seen this problem?

Tanks,

^-flydragon-^

ps: 800MHz, 256MB RAM, WinNT
flydragon
Active Member
Active Member
 
Posts: 6
Joined: June 16th, 2004, 8:44 am

Postby Kambiz » April 17th, 2005, 9:12 pm

Did you try it with RichPrint demo?
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm

Postby flydragon » April 18th, 2005, 11:14 am

thanks for your suggestion!

I found the reason of the problem:
the RichEdit.

I don't know why the RichEdit doesn't work correctly in my program or in with my document.
I found a new RichEdit that show me exactly my document correctly into TPrintPreview.

Therefore the TPrintPreview has no one bug! :)

Thanks by the way!

^-flydragon-^
flydragon
Active Member
Active Member
 
Posts: 6
Joined: June 16th, 2004, 8:44 am


Return to DELPHI AREA Products

Who is online

Users browsing this forum: No registered users and 1 guest

cron