[i18n] A little bug in the version 1.15

Please post bug reports, feature requests, or any question regarding the DELPHI AREA products here.

[i18n] A little bug in the version 1.15

Postby PhilCorleone » January 14th, 2013, 7:35 pm

Hello,

I just have downloaded the i18n component.

When I tried to build the three packages, an error message popped up:

MAINICON ICON "i18nDesign_Icon1.ico" is not found.

The same for the other packages. The targeted files are in *.vrc

I just deleted the line and the package worked out very well.

Hope you investigate the issue.

Appreciated,

Phil.
PhilCorleone
Member
Member
 
Posts: 2
Joined: January 14th, 2013, 7:27 pm
Location: Boston, MA

Re: [i18n] A little bug in the version 1.15

Postby arhangelsoft » January 16th, 2013, 11:19 am

I'm also has got this error in packages for XE2 or below due building it on XE3.
This issue occurs in all components by Kambiz :!:

For fix this you can try:
1. Create icon and name it in package folder.
2. Create package in XE3 and re-add component units.
arhangelsoft
Junior Member
Junior Member
 
Posts: 39
Joined: February 16th, 2012, 9:56 pm
Location: Belarus, Minsk

Re: [i18n] A little bug in the version 1.15

Postby Kambiz » January 18th, 2013, 5:54 pm

All components?! Only the i18n package shipped with .dproj files. The other packages have only .dpk file.

Adding icon is not a solution and in fact it has no sense. A library does not need a main icon.

Apparently the problem is in the way Delphi XE2 and XE3 interpret the .dproj files of older versions. A better solution could be deleting .dproj files and adding .dpk files to the project group. Or just directly opening the .dpk files.
Kambiz
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm


Return to DELPHI AREA Products

Who is online

Users browsing this forum: No registered users and 1 guest

cron