TPicShow and Aero

Please post bug reports, feature requests, or any question regarding the DELPHI AREA products here.

TPicShow and Aero

Postby cralias » August 25th, 2010, 11:27 pm

Hello there!

Given this opportunity, I want to thank author for this excellent component. =D>
Can't believe I've missed it in my searches for components all this time.

There is a little issue, though. When placing TPicShow onto an area, that has been made "glassy" with TGlassFrame (D2010), TPicShow content becomes blended with background of the application, like a mask (can't describe, see attached images). This problem affects pretty much any TImage descendant component I've had, but I have too little knowledge of inner workings of VCL and everything to find what causes it.

Any ideas how this could be resolved while keeping TGlassFrame enabled, please?

P.S. If there's to be more than one TPicShow on the form, so Bottom, Left, Top and Right workaround won't do...
Attachments
without-glassframe-enabled.png
without-glassframe-enabled.png (394.91 KiB) Viewed 657 times
with-glassframe-enabled.png
with-glassframe-enabled.png (512.65 KiB) Viewed 657 times
User avatar
cralias
Member
Member
 
Posts: 4
Joined: August 25th, 2010, 10:20 pm
Location: Latvia

Re: TPicShow and Aero

Postby Kambiz » August 26th, 2010, 8:18 am

It's very interesting.
I tried to fix the problem, but so far no success!
Kambiz
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm


Return to DELPHI AREA Products

Who is online

Users browsing this forum: No registered users and 2 guests

cron