Cannot instal SimpleGraph as component in Delphi 7

Please post bug reports, feature requests, or any question regarding the DELPHI AREA products here.

Cannot instal SimpleGraph as component in Delphi 7

Postby Dreel » October 2nd, 2008, 9:27 pm

I'm trying to install the TSimpleGraph v2.62 but all my attempts failed (
Install Component... has created the project for SimpleGraph but Compile fails with
Code: Select all
[Fatal Error] SimpleGraph.pas(1): Program or unit 'SimpleGraph.pas' recursively uses itself 


Don't know how to install it...need help.

And another one question - how to use it? exe-demo.zip won't work, my app has ran but Graph still not visible.
How to init it properly?
Dreel
Member
Member
 
Posts: 2
Joined: October 2nd, 2008, 9:10 pm

Postby Kambiz » October 5th, 2008, 8:54 am

It seems you didn't install the component properly.

Regarding exe-demo, I don't know what to say. Maybe you didn't load a graph. :-S
Kambiz
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm

Postby Kambiz » October 5th, 2008, 8:55 am

By the way, to install SG, add its files to a new or existing package and build the package. Also, you should add path to SG files to Delphi's library path.

You will find more information on Delphi's help.
Kambiz
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm

Postby Dreel » October 7th, 2008, 4:20 pm

Files must be manually placed in package and compiled for correct installation. It's work now for me.
Thanks.
Dreel
Member
Member
 
Posts: 2
Joined: October 2nd, 2008, 9:10 pm


Return to DELPHI AREA Products

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron