PlayBackRate

Please post bug reports, feature requests, or any question regarding the DELPHI AREA products here.

PlayBackRate

Postby jvoelker » May 21st, 2007, 10:56 am

I am trying to set the playbackrate for the stockaudioplayer but TWaveOutDeviceSupport shows that dsplaybackrate is not supported. How can that be for a standard wave file? What can I do to create a wave file that supports varying the playbackrate?

Thanks.

Jim Voelker
jvoelker
Active Member
Active Member
 
Posts: 9
Joined: December 1st, 2006, 10:57 pm

Postby Kambiz » May 21st, 2007, 1:16 pm

It's not the wave file, the Audio Device does not support PlayBackRate.
Kambiz
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm

Postby jvoelker » May 21st, 2007, 4:48 pm

Thanks for the reply.

I am able to play the same wave file back with Windows Media Player (TActiveMovie) at a slower and faster than normal speeds. So the audio device supports variable playback rates. What then could be causing the problem?

Jim Voelker
jvoelker
Active Member
Active Member
 
Posts: 9
Joined: December 1st, 2006, 10:57 pm

Postby Kambiz » May 21st, 2007, 5:48 pm

It's possible that Windows Media Player uses DirectSound filters.
Kambiz
User avatar
Kambiz
Administrator
Administrator
 
Posts: 2408
Joined: March 7th, 2003, 7:10 pm

Postby Johnny_Bit » May 21st, 2007, 7:08 pm

It does use directsound. Only way of achieving every single neatness with it is to play with ds. no easy way this time.
Thou shalt write the code, not connect the bricks.
Johnny_Bit
VIP Member
VIP Member
 
Posts: 455
Joined: June 15th, 2003, 9:56 am


Return to DELPHI AREA Products

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron